Use ACF field for Open Graph | Feature Requests - All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Use ACF field for Open Graph
September 20, 2014
11:13 pm
Avatar
Kyler Boudreau
Member
Guests
Forum Posts: 47
Member Since:
April 30, 2014
sp_UserOfflineSmall Offline

I’m having a tough time with Open Graph stuff on my site. It doesn’t matter what I select regarding the image and default image, the Facebook debugger just randomly shows various images from the pages.

So here’s the feature request: I’d love to be able to specify an ACF field or fields to pull images from. If I could tell AIOSEO which ACF fields to always use in order, that would ROCK.

I hate this Facebook image BS. They resize, etc. But not I’m on a soap box.

Thanks!!!

September 22, 2014
10:30 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1734
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 3, 2014
4:38 pm
Avatar
Kyler Boudreau
Member
Guests
Forum Posts: 47
Member Since:
April 30, 2014
sp_UserOfflineSmall Offline

Yeah Steve, that’s not working for me because I use ACF. It took me awhile to figure out why it wasn’t working, and then I realized it probably wasn’t going to use an ACF field.

October 3, 2014
5:11 pm
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

November 3, 2014
9:49 pm
Avatar
Kyler Boudreau
Member
Guests
Forum Posts: 47
Member Since:
April 30, 2014
sp_UserOfflineSmall Offline

Peter,

Thanks for responding. My life has been freaking crazy, and I’m finally back to this.

I’d love to be able to have an image upload field, not a text URL. You see, on my site (oilygurus.com) there are profiles built with ACF fields and custom post types. Users have access to their profile, and are wanting a field to upload an image that will be used for social media sharing.

I’ve love to be able to have a default image that’s used (if they don’t upload one) but then have the ACF image field take priority. Is this possible?

If it isn’t, I’d be willing to put some money towards dev time. Also, it would be SWEET if there was a way to trigger Facebook’s Linter tool to refresh their cache when an image is updated, but now I’m asking for the impossible.

Thank you!!!

November 4, 2014
5:53 pm
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

December 6, 2014
1:38 am
Avatar
Kyler Boudreau
Member
Guests
Forum Posts: 47
Member Since:
April 30, 2014
sp_UserOfflineSmall Offline

Peter,

I did some testing on this, and it’s not working for me. In ACF I’ve tried every setting for the image, but each time I get this:

<meta property=”og:title” content=”Essential Oils Santa Monica | Kyler Dennis Boudreau | Oily Gurus” />
<meta property=”og:type” content=”article” />
<meta property=”og:url” content=”http://www.oilygurus.com/kyler-dennis-boudreau/” />
<meta property=”og:image” content=”7513″ />
<meta property=”og:site_name” content=”Oily Gurus” />
<meta property=”article:published_time” content=”2014-06-30T20:41:21Z” />
<meta property=”article:modified_time” content=”2014-12-05T22:23:47Z” />
<meta name=”twitter:card” content=”summary” />
<meta itemprop=”image” content=”7513″ />

You’ll see the image is just pulling the image ID, not the URL. However, if I add this same field to a template file using this:

<img src=”<?php the_field(‘image’); ?>”>

It prints the image URL out just fine, and I get this:

<img src=”http://www.oilygurus.com/wp-co…../daddy.jpg“> 

And that’s the image I uploaded.

Is there any way to get this to work with ACF? Thanks man!

December 8, 2014
11:51 am
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

December 12, 2014
3:49 pm
Avatar
Kyler Boudreau
Member
Guests
Forum Posts: 47
Member Since:
April 30, 2014
sp_UserOfflineSmall Offline

Thanks Peter.

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
17 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 33

Members: 18391

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1779

Posts: 7539

Newest Members:

hüseyin uçar

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAsh R

[i]
[i]
Skip to toolbar