Problem - Website went from 7 keywords to none | General - All in One SEO Pack Pro Forum | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Problem - Website went from 7 keywords to none
November 22, 2017
5:26 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

I have redisigned a website and installed AIOSEO Pro on it.  I have had this program for years now and just don’t seem to have any results getting sites to rank for anything.  I understand content is king, think I have my keywords placed correctly.  The site used to show several keywords on spyfu.com but now it’s none. 

 

The site is http://www.abbeyrosewelshterriers.comspyfu.jpegImage Enlarger10

sp_PlupAttachments Attachments
November 22, 2017
8:09 pm
Avatar
Michael Torbert
Admin
Forum Posts: 350
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

November 28, 2017
1:33 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

I appreciate that you cannot give me general SEO advice, nor do I expect SEO training. 

My question was not how do I improve my ranking, my question is what is it about the settings in your plugin that make my sites disappear from view.

I have been a “member” since 2011 – have paid for your plug in year after year and get no results or negative results.  I have studied SEO – taken seminars both in person and on-line.  I feel I have a good understanding of what is required and achieve very good results with sites using other SEO plugins.  Yours was my “go-to” because it is so very highly recommened and I feel that I have a large investment in your system having paid for it since 2011.  

Bottom line, it isn’t working correctly and I cannot figure out which of the settings is wrong, or how I am using the plugin incorrectly.

If you cannot help, that’s fine – I will just switch.

Kris

November 28, 2017
1:48 pm
Avatar
Michael Torbert
Admin
Forum Posts: 350
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

November 28, 2017
1:50 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

Sorry – I made a mistake, I upgraded to the SEO pro in 2013 so I have only been using your plugin for 4 years, not 6 years!

November 28, 2017
1:54 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

I thought I expressed myself relatively clearly.  The problem I am having is that when I add your plugin to a site, and it has happened to several sites over the last year or so, with no other changes to content, the site simply stops ranking.  When I remove your plugin and use another plug in, the site ranks higher within a month.  Again, no change to content.

I assume that something is wrong with the setttings which is why I asked the question.

Please tell me what information you need in order to tell me where the problem is.

 

Kris

November 28, 2017
2:37 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

December 4, 2017
6:44 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

I know the site is indexed.  I understand NOINDEX.  My question had nothing to do with indexing.  

Your statement that keywords have zero value in SEO is totally opposite from everything I have been taught, have read, and have tried to implement.  I have been taught keyword research, keyword implementation, and keyword optimization while keeping content human, interesting, informative and relative to the subject you wish to be “seen” for is what is important. 

I have attended several webinars, including at least one which was taught by Micheal Tolbert, where we were taught that the settings in your plugin were critical to obtaining the best possible results when trying to get a site to rank higher in the search engine results for a particular subject. I do not understand the implications of all the settings in your plugin which is why when I exhausted all other avenues, I requested support.

Everyone that I have learned from has great respect for your company and the work you do.  I really did try many things before I requested support.  

The very odd thing is that when I turn your plugin on, the site falls in ranking – not immediately, but over the course of a month or so.  If I replace your plugin with another, the ranking improves. It is for this reason, I thought that maybe one of the mysterious settings was incorrect.

I do not understand what the problem is.  I have spent too much time, money, and effort attempting to use your plugin to receive the answers provided above.

I quit.

Kris

February 23, 2018
10:20 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

Mary-SEO.jpegImage Enlargerhttp://www.abbeyrosewelshterriers.com

 

Well, it’s been a couple months since I asked for advice or help back in November and December 2017 – see the thread above.   I deactivated your plugin and activated a competitor’s plug in.  

I asked for assistance because I knew something was wrong and I still don’t know what the problem is or, rather, was.  

There have been a couple of posts to the site but no major content added or changed – nothing that would justify a substantial increase.  The only real change is the removal of the All in one SEO Pro plugin. 

Take a look at what happened with the site when I deactivated your plugin!!!  There had to be something wrong with some setting in the plugin for this to happen.  

sp_PlupAttachments Attachments
February 24, 2018
4:32 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

February 24, 2018
8:01 am
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

Once again, the problem is not whether the site is indexed or not. I always manually submit a sitemap and request Google to index through Google Search Console.  I know your plugin is supposed to submit the sitemap to Google and to Bing, but I have always had to submit manually.

The site is indexed – that was not the issue.  I think I made that perfectly clear.

I asked back in November about the settings within the plugin, thinking I must have some setting wrong.  Your answer “Google ranks your site based on the quality of your content not some setting in an SEO plugin.  Google does not use keywords to rank sites, keywords have zero value in SEO or on Google.  ”  makes absolutely no sense to me and was of no help whatsoever.

 

Kris5

February 26, 2018
5:13 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

May 4, 2018
10:28 am
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

Thank you for the offer to check the settings to see why SEO meta is not being output by All in one SEO Pack Pro. 

I originally asked for assistance with this in November of 2017 and was told that your plugin has” no setting that would cause you to immediately fall in rankings”.  I honestly had an issue and it was adversely affecting every site I used your plug in on. 

I was your customer for many years and used your product exclusively.

I spent forever studying and going over and over all the material and information I have, including webinars, books, tutorials, etc., to try and figure out what I was doing wrong.  I could understand that if I was not providing content that was of superior quality or optimized correctly, then my results in SERP would suffer but my content was as good as if not better than my competitors.  Sites would FALL in ranking when I activiated your plug in which is why I initially asked my specific question in November 2017.

I meant what I wrote in December – I quit after almost 5 years of using and paying for your Pro plugin.  I am still puzzled by your statement that keywords and their placement have no impact on SEO and went back to read it because I am attending another webinar this morning on SEO and wanted to make sure I understood your statement and have it fresh in my mind prior to the webinar. 

My sites are ranking in the SERP’s since I removed your plugin and are improving each month – probably because I am improving now that I have tools with which to measure, quantify, and evaluate results.  I noticed today, almost 6 months from my original question, that you now recognize there may be an issue with the setting within the AIO SEO plugin on my site – way too late, it’s deactivated, deleted, and replaced with another.  I am hugely disappointed.

Kris

May 15, 2018
9:16 pm
Avatar
kris
Member
AIOSEOP
Forum Posts: 12
Member Since:
June 5, 2013
sp_UserOfflineSmall Offline

Here I am again….  After struggling for almost a year, adding content at least three times a week to another of my clients web sites, and being told that there is no setting that could be adjusted and that your plugin couldn’t possibly be causing my site not to rank I changed to a different SEO plugin.  Again, it took about a month, but the site is doing great.  It doesn’t have huge numbers as it is a very niche type site, but it is now getting enough organic traffic to be picked up by tools like spyfu, etc.  

 

I cannot believe I wasted so much money and even more importantly so very much time on your product.  I was a loyal customer for many years.  When I asked for help, several times on several different sites over the course of a couple years, none was offered.  To be told “Unfortunately we’re not able to give general SEO advice.” was of no use to me whatsoever!

 

Kris

May 16, 2018
8:03 am
Avatar
Michael Torbert
Admin
Forum Posts: 350
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
12 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 18944

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1823

Posts: 7738

Newest Members:

Harte Londo

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAsh R

[i]
[i]
Skip to toolbar