Issue with Upgrade to 2.4.11.1 | Installation / Upgrading – All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Issue with Upgrade to 2.4.11.1
December 11, 2016
8:53 pm
Avatar
Raman Muthukrishnan
Member
Guests
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi SemperPlugins,

Today I upgraded SEO Pack Pro to 2.4.11.1

In my nginx, I received the following error:

2016/12/12 00:53:47 [error] 1259#0: *10358 FastCGI sent in stderr: “PHP message: PHP Warning:  require_once(/var/www/html/efs/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/inc/aioseop_functions.php): failed to open stream: No such file or directory in /var/www/html/efs/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/all_in_one_seo_pack.php on line 377

PHP message: PHP Fatal error:  require_once(): Failed opening required ‘/var/www/html/efs/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/inc/aioseop_functions.php’ (include_path=’.:/usr/share/php:/usr/share/pear’) in /var/www/html/efs/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/all_in_one_seo_pack.php on line 377″ while reading response header from upstream, client: 172.31.38.90, server: satramana.org, request: “GET /web/index.php HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “172.31.34.245”

 

Then I went to the plugins directiory and saw that there is no folder for all-in-one-seo-pack-pro. Instead the folder name was aioseop-pro-2.4.11.1.

I did a symbolic link of the folder to all-in-one-seo-pack-pro to fix the issue. Then our website was back up.

Could you check why it happened and what is the right solution?

 

https://satramana.org/web

Thank you,

Raman

December 12, 2016
9:23 am
Avatar
Michael Torbert
Admin
Forum Posts: 398
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

December 12, 2016
2:24 pm
Avatar
Raman Muthukrishnan
Member
Guests
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Michael,

Thank you for your email.

Do you mean to say aioseop-pro-2.4.11.1 is the correct directory name for the plugin?

Is it possible that due to caching plugin (we use wp-rocket), there is a cached page referring to the old directory name?

I am hesitant to try again as the whole website comes down with the error.

Thank you,

Raman

December 13, 2016
9:31 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1956
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

January 30, 2017
2:14 pm
Avatar
mattocks
Member
AIOSEOP
Forum Posts: 5
Member Since:
December 29, 2015
sp_UserOfflineSmall Offline

I just downloaded the upgrade of 2.4.11.1 and did a fresh install. Getting this error when trying to activate: Sorry, you are not allowed to access this page.

 

Its referring to the aioseop_class.php.

 

I was able to re-enter my key from a revert and then I did the upgrade from the plugin manager page in wordpress ( maybe thinking versioning was off on link I was given )

 

Any thoughts on this? I did try the “folder” name change by adding in the”-pro” but nothing new to report from that.

 

Thanks,

Mattocks

January 30, 2017
2:35 pm
Avatar
mattocks
Member
AIOSEOP
Forum Posts: 5
Member Since:
December 29, 2015
sp_UserOfflineSmall Offline

I also saw a response to this on :

 

I checked to make sure that the admin has this set in user meta:

https://wordpress.org/support/topic/sorry-you-are-not-allowed-to-access-this-page-5/

a:1:{s:13:”administrator”;b:1;}

Had to disable All in one SEO Pack all together. Its actually crashing my admin.. not front end.

January 30, 2017
2:48 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1956
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

January 30, 2017
4:55 pm
Avatar
mattocks
Member
AIOSEOP
Forum Posts: 5
Member Since:
December 29, 2015
sp_UserOfflineSmall Offline

Sorry, Meant to say I verified that “a:1:{s:13:”administrator”;b:1;}”

 

I did do a fresh install of the plugin . I moved the other into a folder called “disabled” then uploaded the whole new plugin. I am doing this through FTP as well.

I tried this on two different WP installs I have and am getting the same results.

Please advise –

January 30, 2017
5:03 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1956
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

January 30, 2017
5:35 pm
Avatar
mattocks
Member
AIOSEOP
Forum Posts: 5
Member Since:
December 29, 2015
sp_UserOfflineSmall Offline

Sent credentials. – Please use second form entry. I created a new user for you as administrator.

I do have full root SSH if we need to do anything at the server level and it’s running on cloud linux so I can qwuickly swap PHP versions if needed.

January 30, 2017
6:21 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1956
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

January 30, 2017
10:54 pm
Avatar
mattocks
Member
AIOSEOP
Forum Posts: 5
Member Since:
December 29, 2015
sp_UserOfflineSmall Offline

Steve,

Thanks for getting that resolved!

Thanks! Which error log were you referencing for that? If we can get to it before you guys I’ll email my findings and fix.

January 31, 2017
9:24 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1956
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

February 1, 2017
11:05 pm
Avatar
Michael Torbert
Admin
Forum Posts: 398
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
27 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 20478

Moderators: 1

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1944

Posts: 8357

Newest Members:

Vinh Tran

Moderators: Dawa Liu

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAshish Ravi

[i]
[i]
Skip to toolbar