Multi-Language / single geography optimisations | Optimizing All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Multi-Language / single geography optimisations
July 26, 2018
10:30 am
Avatar
Sascha Ehrentraut
Barcelona, Spain
Member
AIOSEOP
Forum Posts: 10
Member Since:
March 13, 2018
sp_UserOfflineSmall Offline

Hallo, Hello, Hola!

I have a site for Barcelona, Spain so I need three languages – English, Spanish and Catalan. The base language is English and the other two languages I have put in subdirectories – /en/ and /ca/. 8 months ago I re-launched this site with the three languages (prior it was 1 language). When I add more content I pretty much always add all 3 languages. This is the site: Instrument Rentals. 

Since the site launch I have seen a very positive jump in traffic, so whats the problem? The increase is like 95% from english terms which is why I am posting this question – I want to confirm that either IT IS or IT IS NOT an onsite causing the ES and CA language to underperform. 

Below is a list of things I have considered. 

Hreflang:
This is setup and looks to be working. Not sure if there is anything more or better that can be done here. 

<link rel=”alternate” hreflang=”en” href=”https://www.instrumentrentalbarcelona.com/product/camps-eco-ronda-guitar-1/” />
<link rel=”alternate” hreflang=”es” href=”https://www.instrumentrentalbarcelona.com/es/product/guitarra-camps-eco-ronda/” />
<link rel=”alternate” hreflang=”ca” href=”https://www.instrumentrentalbarcelona.com/ca/product/guitarra-camps-eco-ronda/” />

Canonical Tags: 

I have selected the default option. Nothing special done here but how do I know there arnt any errors. For example: I can see all the tags are in place on the page for itself but if there are other pages that are duplicates that should have the tag pointing to the Canonical version of itself don’t have it. Or in other words the duplicate pages have a tag but it points to itself. 

Pages indexed: 

Now I would expect there to be a difference but 2 to 3 times more seems to much but maybe it is not? Also ES and CA should be 1 to 1 but this is separate issue which I suspect I will need to dig into (but if anyone knows a trick to figure out the missing 140 pages between the ES and CA that would be great)

site:https://www.instrumentrentalbarcelona.com/ = 3,800

site:https://www.instrumentrentalbarcelona.com/es = 1,060

site:https://www.instrumentrentalbarcelona.com/ca = 1,200

(Competition: 

Yes not onsite but just to acknowledge that there might be more competition in the other two languages. It is possible that it is a coincidence that the base language is out performing the other two languages significantly due to this.

Link-building:

Again just to acknowledge that this is something I will def look into for language specific pages and sources.)

Any advice, tips, tricks anyone might have to get me to confirm that it either IS or IS NOT onsite error causing my two other languages to underperforming would be most welcome. 

I am hoping that there is a silver bullet, unlikely, but hoping. 🙂

Many Thanks,
Sascha

July 26, 2018
11:24 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1869
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 31, 2018
4:37 am
Avatar
Sascha Ehrentraut
Barcelona, Spain
Member
AIOSEOP
Forum Posts: 10
Member Since:
March 13, 2018
sp_UserOfflineSmall Offline

Hi Steve,

Thats great!

  1. I have selected redirect to post parent and media noindex. thank you for the tips! Sitemap I am guessing will update automatically if it is needed? 
  2. Another idea: There are way to many queries on the site. I have taken it from like 700 queries down to about 400 (caching and other tweaks). But it is still way to much. WPML on the home page alone does a 100! queries. And est. 86 to 94 on product pages. Seems excessive? Any tips or thoughts for that?

Thank you,

Sascha

July 31, 2018
6:21 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1869
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

August 1, 2018
5:42 am
Avatar
Sascha Ehrentraut
Barcelona, Spain
Member
AIOSEOP
Forum Posts: 10
Member Since:
March 13, 2018
sp_UserOfflineSmall Offline

Great thank you Steve – very helpful. 

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
28 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 19970

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1896

Posts: 8087

Newest Members:

Luigi Maragna

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAshish Ravi

[i]
[i]
Skip to toolbar