Bad Bot Blocker Blocking Stripe merchant processor requests | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Bad Bot Blocker Blocking Stripe merchant processor requests
March 9, 2016
12:13 pm
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

I really love your plugin, and you’ve provided great support and new features and such. But I’m endlessly frustrated with the plugin right now. I spent probably 6+ valuable hours the yesterday and today trying to figure out why Stripe couldn’t access my webhooks endpoints on my server. I use Gravity Forms with the Stripe addon. I removed iThemes Security, whitelisted all of Stripe’s IP’s and tons of other stuff, but couldn’t figure out why my site was still returning a 503 error to Stripe, when the URL could be accessed just fine via browser and a number of other methods. I’ve gone back and forth with my webhost’s support, Stripe support, and Gravity Forms support.

I was looking at my Apache logs just now and saw a blocked bot, and thought of this plugin. Stripe isn’t a bot, and it’s not listed as a bot in the bad bot list. So I have no idea why, but the Bad Bot Blocker in AIO is blocking stripe. I turned it off, and immediately Stripe could connect without issue!

I don’t know why or what’s going on, and I’m happy to provide whatever info you request to help get it resolved. But Stripe shouldn’t be blocked under any circumstances.

March 9, 2016
12:20 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1787
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

March 9, 2016
12:28 pm
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

Well, I can’t tell you why, but it is. If I click the “Track Blocked Bots” option, here’s what it gives me in the log area at the bottom:

 

2016-03-09 17:01:07 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 17:00:08 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:53:59 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:53:39 Blocked bot with IP 66.249.74.8 -- matched user agent DoCoMo/2.0 N905i(c100;TB;W24H16) (compatible; Googlebot-Mobile/2.1; +http://www.google.com/bot.html) found in blocklist.
2016-03-09 16:52:00 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:50:59 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:49:47 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:47:51 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:47:13 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:43:40 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:43:03 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:40:36 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:40:01 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:39:46 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:37:57 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:37:35 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:36:03 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:35:02 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:32:18 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:30:48 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:30:26 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:28:36 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:28:03 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:27:32 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:19:50 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:18:10 Blocked bot with IP 54.187.174.169 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:17:52 Blocked bot with IP 54.187.205.235 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.
2016-03-09 16:15:29 Blocked bot with IP 54.187.216.72 -- matched user agent Stripe/1.0 (+https://stripe.com/docs/webhooks) found in blocklist.

I don’t see it in the User Agent Blocklist, so I have no idea how/why it’s finding a match, but it is.

March 9, 2016
12:38 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1787
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

March 9, 2016
12:43 pm
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

I never enabled that option. When I thought iThemes Security might be the culprit, I disabled it, then went into the .htaccess and cleared everything but the default WordPress permalinks section. It was entirely empty, but that part. Still 503 every time. Nothing helped until I unchecked the 1 box I had checked in Bad Bots Blocker: Block Bad Bots. Then it all worked. It was only after that, that I checked the tracking checkbox to see the log. But up to that point only 1 had been checked, the very first option that turns it on.

March 9, 2016
12:47 pm
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

I somehow missed your request for the Apache logs. Do you still want those? If so, what’s a safe way to send them?

March 10, 2016
8:08 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1787
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

March 10, 2016
10:27 am
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

Okay. Thanks. Let me know if you need any more info from me. It was really surprising to me too, and the reason I didn’t check there after many hours looking all over, trying to find the issue. It’s not like my list of bad bots is showing Stripe either. It’s not in the list, that I can see. But for some reason is being seen as a match.

March 10, 2016
10:33 am
Avatar
Tevya Washburn
Member
AIOSEOP
Forum Posts: 44
Member Since:
May 22, 2012
sp_UserOfflineSmall Offline

I just Googled it and found your Github issue: https://github.com/semperfiwebdesign/all-in-one-seo-pack/issues/34

There’s at least 1 other you could probably add: https://wordpress.org/support/topic/stripe-hooks?replies=4

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
23 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 18919

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1822

Posts: 7732

Newest Members:

mliebethal

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAsh R

[i]
[i]
Skip to toolbar