Facebook metadata generates errors Google structured data tool | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
Facebook metadata generates errors Google structured data tool
July 14, 2016
10:40 am
Avatar
_351
Member
Guests
Forum Posts: 5
Member Since:
July 7, 2016
sp_UserOfflineSmall Offline

Hello,

When i enable social meta and fill in Facebook meta.

I can Choose type of website I have chosen for “Website”:

  • Blog
  • Website
  • Article

I also can enable Facebook meta for “products”. My first question is, is it a good idea to enable this setting when i use WooCommerce?
When I enable this setting I set itemtype to product.

This will add “itemtype=”http://schema.org/Product” to the html tag.

After enabling the social meta i get errors in the Google Structured Data tool. See for example: https://www.fysio123.nl/product/mysole-daily-comfort-inlegzolen/

I saw also following question http://stackoverflow.com/quest…..-meta-tags

where they suggest typeof=”schema:WebPage” or typeof=”schema:Product” in html tag instead of your solution with the itemtype.

I don’t know if this a good suggestion, but i don’t like the error messages in the Google Structured Data tool.

Hopefully everything is clear and can you give me some information / solution about this topic.

Thank you.

July 14, 2016
11:03 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 14, 2016
12:05 pm
Avatar
_351
Member
Guests
Forum Posts: 5
Member Since:
July 7, 2016
sp_UserOfflineSmall Offline

Thanks for the answer.

The breadcrumb is set by woocommerce in wc-template-functions.php

if ( ! function_exists( ‘woocommerce_breadcrumb’ ) ) {

/**
* Output the WooCommerce Breadcrumb.
*
* @param array $args
*/
function woocommerce_breadcrumb( $args = array() ) {
$args = wp_parse_args( $args, apply_filters( ‘woocommerce_breadcrumb_defaults’, array(
‘delimiter’ => ‘ / ’,
‘wrap_before’ => ‘<nav class=”woocommerce-breadcrumb” ‘ . ( is_single() ? ‘itemprop=”breadcrumb”‘ : ” ) . ‘>’,
‘wrap_after’ => ‘</nav>’,
‘before’ => ”,
‘after’ => ”,
‘home’ => _x( ‘Home’, ‘breadcrumb’, ‘woocommerce’ )
) ) );

$breadcrumbs = new WC_Breadcrumb();

if ( ! empty( $args[‘home’] ) ) {
$breadcrumbs->add_crumb( $args[‘home’], apply_filters( ‘woocommerce_breadcrumb_home_url’, home_url() ) );
}

$args[‘breadcrumb’] = $breadcrumbs->generate();

wc_get_template( ‘global/breadcrumb.php’, $args );
}
}

, so i think there is some compatibility issues.

You said: “I believe the product name should come from WooCommerce.” Then there is another compatibility issue.

July 14, 2016
3:21 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 14, 2016
4:55 pm
Avatar
_351
Member
Guests
Forum Posts: 5
Member Since:
July 7, 2016
sp_UserOfflineSmall Offline

All in one Seo is inserting the itemtype “product” in the html tag (which is on the wrong level, i’ll think) which causes the problems with the breadcrumb schema attribute.

If All in one seo is not inserting the itemtype on the html level there is no problem.

Is there information available that facebook needs this property? Can you refer to documentation about this.

I don’t think this is a woocommerce problem…

July 14, 2016
5:02 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 14, 2016
8:01 pm
Avatar
_351
Member
Guests
Forum Posts: 5
Member Since:
July 7, 2016
sp_UserOfflineSmall Offline

i’am aware of this option.

i can also disable the plugin, then the problem is also gone.

i think this the best solution and ask my money back.

thank you for youre time.

July 14, 2016
8:06 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 1789
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 19, 2016
3:10 pm
Avatar
Michael Torbert
Admin
Forum Posts: 350
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 19, 2016
6:10 pm
Avatar
_351
Member
Guests
Forum Posts: 5
Member Since:
July 7, 2016
sp_UserOfflineSmall Offline

Thank you very much. Exactly what i need.

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
18 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 18944

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1823

Posts: 7738

Newest Members:

Harte Londo

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAsh R

[i]
[i]
Skip to toolbar