get_home_path() undefined | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
get_home_path() undefined
July 1, 2016
2:29 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi,

I just now upgraded to the latest all-in-one-seo-pack-pro, and the picture gallery stopped working.

The Nginx error log has the following error: Could you tell what could be the issue and how I could fix it?

 

2016/07/01 06:18:28 [error] 1136#0: *807 FastCGI sent in stderr: “PHP message: PHP Fatal error:  Call to undefined function get_home_path() in /data/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/modules/aioseop_sitemap.php on line 1370” while reading response header from upstream, client: 172.31.38.90, server: satramana.org, request: “GET /web/gallery/pictures/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “satramana.org”, referrer: “https://satramana.org/web/”

2016/07/01 06:19:48 [error] 1136#0: *859 FastCGI sent in stderr: “PHP message: PHP Fatal error:  Call to undefined function get_home_path() in /data/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/modules/aioseop_sitemap.php on line 1370” while reading response header from upstream, client: 172.31.19.182, server: satramana.org, request: “GET /web/bwg_album/2016/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “satramana.org”

Thank you,

Raman

July 1, 2016
9:28 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1688
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 1, 2016
9:50 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Steve,

I reverted back to non-pro version as our website photo gallery and calendar became non-functional.

I will re-install the pro version and send you the login information.

THere is no ftp information as this is an Amazon EC2 instance, and they have a ssh login with keys. What should we do here?

 

Thanks

Raman

July 1, 2016
9:52 am
Avatar
Michael Torbert
Admin
Forum Posts: 299
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 1, 2016
10:42 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Michael,

Sorry for the delay.
Another plugin author is doing a fix to the photo gallery. Hence I am not installing the Pro yet.

I will install it on Monday morning so that you can look into it.

One other point: After the Pro installation, the wp-admin access was also not working. I had also upgraded Photo-gallery plugin at around the same time. I do not know if they conflict with each other.

Thank you,

Raman

July 1, 2016
10:53 am
Avatar
Michael Torbert
Admin
Forum Posts: 299
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 1, 2016
2:05 pm
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Michael,

The photo gallery is from Web-Dorado.

Thanks,

Raman

July 3, 2016
8:55 pm
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

I have both the All-In-On SEO and Pro version.

When I activate any one of them, the picture gallery at the following link stops working.

The older version of All in One SEO was working for us.

Could you check?

I have sent the admin/password details.

Below is the link to the picture gallery:

https://satramana.org/web/gallery/pictures/

Right now you will see the albums. After you active the Pro or non-pro version, the albums disappear.

Thank you very much for the help,

Raman

July 5, 2016
9:55 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1688
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 5, 2016
10:53 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Steve,

You can check: https://satramana.org/web/gallery/pictures/

The pictures are no longer visible.

Also, the nginx error is still there:

2016/07/05 14:07:40 [error] 1124#0: *5878 FastCGI sent in stderr: “PHP message: PHP Fatal error:  Call to undefined function get_home_path() in /data/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/modules/aioseop_sitemap.php on line 1370” while reading response header from upstream, client: 172.31.38.90, server: satramana.org, request: “GET /web/gallery/pictures/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “satramana.org”, referrer: “https://satramana.org/”

2016/07/05 14:07:49 [error] 1124#0: *5905 FastCGI sent in stderr: “PHP message: PHP Fatal error:  Call to undefined function get_home_path() in /data/wordpress/web/wp-content/plugins/all-in-one-seo-pack-pro/modules/aioseop_sitemap.php on line 1370” while reading response header from upstream, client: 172.31.19.182, server: satramana.org, request: “GET /web/bwg_album/2016/ HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “satramana.org”

Could you try to check as soon as possible? I realize that I should have had a separate development site to debug this. Currently the visitors to our website will be affected by it. Hence the request.

Thanks,
Raman

July 5, 2016
10:57 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Steve,

Since you are not online now, I just now de-activated the All In One SEO Pack Pro so that the pictures are visible again.

To reproduce the problem, you will need to activate the All In One SEO Pack Pro.

Thank you,

Raman

July 5, 2016
11:09 am
Avatar
Steve Mortiboy
Admin
Forum Posts: 1688
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 5, 2016
11:50 am
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Steve,

Thank you for looking into this.

I tried the following:

1. I upgraded Page Builder to the latest version 2.4.10 and activated All in One SEO Pack Pro. But the issue is still there with the page: 

2. I deactivated Page Builder and activated All in One SEO Pack Pro. I still see the problem. (Also, the page formatting has issues if I disable page builder)

 

Just FYI: I think, the previous version of All In One SEO did not have this issue.

Could you suggest any workaround?

You can also call me in case talking on the phone will help.

 

Thank you,

Raman

July 5, 2016
12:53 pm
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Steve,

I found the following discussion about undefined get_home_path():

https://wordpress.org/support/topic/490-php-fatal-error-call-to-undefined-function-get_home_path

There is also a fix suggested there.<br />

Could you take a look?

Thank you,

Raman

July 5, 2016
2:23 pm
Avatar
Michael Torbert
Admin
Forum Posts: 299
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 5, 2016
3:23 pm
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Thank you very much Michael and Steve for your efforts in resolving this. It is helpful.

I will try it today by Pacific evening time and get back to you.

Thank you,

Raman

July 5, 2016
4:58 pm
Avatar
_284
Member
Members

AIOSEOP
Forum Posts: 13
Member Since:
June 29, 2016
sp_UserOfflineSmall Offline

Hi Michael,

I see that version 2.4.6 of All In One SEO Pro is enabled in the site, and it is working.

Do I need to download the 2.4.6.1 version? The download link that I have in the email receipt still downloads 2.4.6 version. I see that version in one of the php files.

 

Thank you very much for the help,

Raman

July 5, 2016
5:03 pm
Avatar
Michael Torbert
Admin
Forum Posts: 299
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

July 5, 2016
5:33 pm
Avatar
Michael Torbert
Admin
Forum Posts: 299
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
19 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 14

Members: 18059

Moderators: 1

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1738

Posts: 7300

Newest Members:

DOVEL SARL

Moderators: Dawa Liu

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAsh R

[i]
[i]
Skip to toolbar