New "Additional Headers" area | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
New "Additional Headers" area
September 27, 2012
10:01 am
Avatar
tbates
Member
Guests
Forum Posts: 20
Member Since:
February 20, 2012
sp_UserOfflineSmall Offline

Originally, there were only three Additional Headers areas.
1. Additional Post Headers
2. Additional Page Headers
3. Additional Home Headers

A few versions back, not long ago, you guys added the fourth, “Additional Front Page Headers” and I completely understand and appreciate the feature. However, on my pages that were ALREADY static front page, any additional headers I had for “Home” that were being used, automatically got dropped during the upgrade, because it now was looking for “Front Page”. This was a problem, because I had upgraded a couple hundred websites assuming data would not get swapped like that.

Anything that can be done? This could be a potential problem for anyone else upgrading any AIOSEOP, because we have to upgrade and go in to each one and manually copy it over.

Frown

September 27, 2012
10:05 am
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

September 27, 2012
10:13 am
Avatar
tbates
Member
Guests
Forum Posts: 20
Member Since:
February 20, 2012
sp_UserOfflineSmall Offline

Yes.

Most of the sites have a static front page selecting a wordpress Page (obviously). The sites that have this setting were actually using the Home Additional Headers from the version version. Now it’s Blog Page or Front Page, which is perfect because it can separate the two. I did not check the code, but i imagine it was checking for is_front_page() || is_home() since there was only one spot for Home. I had never had an issue with this field before, nor am I having an issue “with it” now. The main thing is with the upgrade, there now are 4 blocks and 1 of them is empty when previously all 3 were full. This new box is the Front Page box or whichever, as I assume “Home” got renamed to “Blog” per your post above.

Please see this image: http://apt25.net/aioseop-headers1.png

This is what I get after an upgrade on the NON-PRO (2.0 doesn’t seem to be released yet on the FREE). The Front Page area is empty. This happened before the 2.0 release I think (though not sure because I just noticed this issue). Basically, I checked one of my websites (screen shot from AIOSEOP settings above) and noticed the homepage of the site had no custom headers. I checked AISEOP and noticed a 4th headers area, and one was blank… So my headers were gone! No big deal, they were still in the Home/Blog Additional Headers and I just had to copy it over… but I had to login to 200+ websites FREE and PRO and fix this.

This is a huge problem, because any sites that have a static front page setting using the Home Additional Headers area will lose their frontpage headers (not LOSE but they wont be showing) up unless the user copies it.

September 27, 2012
10:17 am
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

September 27, 2012
10:24 am
Avatar
tbates
Member
Guests
Forum Posts: 20
Member Since:
February 20, 2012
sp_UserOfflineSmall Offline

The screenshot above is directly from the site http://www.foxruncabins.com. As you can see, the following code is in my 3 of 4 header fields (it’s all the same, but the 4th is empty because it was created by the update).

<meta name=”revisit-after” content=”3 days” />
<meta name=”robots” content=”index,follow” />
<meta name=”GOOGLEBOT” content=”index,follow” />
<meta name=”google-site-verification” content=”HIDDEN” />
<META name=”y_key” content=”HIDDEN” />
<meta name=”msvalidate.01″ content=”HIDDEN” />

This code does not appear on the homepage, because it’s a static home page and the Front Page Additional Headers is blank. So it’s not pulling from the Home area (notice this is the FREE version). I did go and check my 2.0 and see that it is working fine. However, I have so many sites that I haven’t upgraded all the old ones to the PRO version since I purchased, because it’s not necessary. Obviously if I ever get into going back to those I would, but I have upgraded those FREE versions to the latest, and they are all pulling no custom headers for home.

So my apologies in that this is not a PRO error, since I can definately see the PRO is pulling my Blog headers when Front Page is empty.

We have many many many many sites that have not been upgraded to PRO. Maybe you can patch the FREE one with this fix that is on the PRO already, and have it have a PRO upgrade button where you can enter you license key and upgrade it, or something.

It’s easier for me to open up 50 internet windows at a time rather than FTP in to multiple domains.

September 27, 2012
10:35 am
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

September 27, 2012
12:20 pm
Avatar
tbates
Member
Guests
Forum Posts: 20
Member Since:
February 20, 2012
sp_UserOfflineSmall Offline

The thing is, when the 4th headers became availalable, all of my sites stopped showing the Home Headers I already had in place because Home is now the Blog page and Front Page was created and emptied.

I now have to go through each of my FREE installs that I upgraded and copy it over because EVERY ONE of them now do not show my additional headers on the homepage.

September 27, 2012
12:29 pm
Avatar
Peter Baylies
Admin
Forum Posts: 578
Member Since:
October 16, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
47 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 19970

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1896

Posts: 8088

Newest Members:

Luigi Maragna

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAshish Ravi

[i]
[i]
Skip to toolbar