PHP 7 compatibility | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar

Lost password?
Advanced Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

sp_Feed Topic RSS sp_TopicIcon
PHP 7 compatibility
September 13, 2018
2:49 pm
Avatar
Hannah Mattheisen
New Member
AIOSEOP
Forum Posts: 1
Member Since:
March 10, 2017
sp_UserOfflineSmall Offline

Hi,

I’m trying to upgrade our site to PHP7, but the compatibility checker is showing issues:

 

FILE: /nas/content/live/montanatom/wp-content/plugins/all-in-one-seo-pack-pro/pro/plugin-updates/vendor/ParsedownLegacy.php
—————————————————————————————————————————————————————————-
FOUND 1 ERROR AFFECTING 1 LINE
—————————————————————————————————————————————————————————-
1412 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.
—————————————————————————————————————————————————————————-

 

Any thoughts, fixes, suggestions?  Thanks!

September 13, 2018
2:52 pm
Avatar
Michael Torbert
Admin
Forum Posts: 380
Member Since:
October 13, 2011
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York

Most Users Ever Online: 964

Currently Online:
32 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Member Stats:

Guest Posters: 35

Members: 19757

Moderators: 0

Admins: 8

Forum Stats:

Groups: 4

Forums: 28

Topics: 1887

Posts: 8040

Newest Members:

Raly Vak

Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve KlasenArnaud BroesAshish Ravi

[i]
[i]
Skip to toolbar