Sitemap Times Out with Woocommerce Products added | Troubleshooting All in One SEO Pack Pro | Support | Semper Plugins

Avatar
Lost password?
Advanced Search
Forum Scope


Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_Feed Topic RSS sp_TopicIcon
Sitemap Times Out with Woocommerce Products added
October 29, 2019
4:31 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

If I add my Woocommerce products to the sitemap it times out when accessed (4500+ products).

 

Current AIO settings:

Enable Sitemap Indexes – checked

Maximum Posts Per Sitemap Page – 250

Exclude Images – checked

Dynamically Generate Sitemap – checked

 

PHP Settings

Version – 7.2

Memory limit – 2GB

max_execution_time – 600

October 29, 2019
4:55 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 29, 2019
5:08 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

Product categories is the only thing checked under taxonomies. Removing it doesn’t help.

Removing products from the sitemap resolves the issue.

URL – https://www.heritagebuilding.c…..itemap.xml

Currently products is not checked. Would you like me to check it?

October 29, 2019
5:17 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 29, 2019
5:26 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

Hi Steve, 

I swapped hosting a few months back when I was having this issue amongst others. I haven’t looked at the sitemap thing since then due to being extremely busy. 

I have just emailed the host to find out what they can suggest or do. If I don’t have any success with them I’ll get you to investigate further.

October 29, 2019
8:53 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

The host is denying that there is any performance issue with the server so I have posted my login info at the form you suggested.

October 29, 2019
8:57 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 30, 2019
1:04 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 30, 2019
2:10 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

Hi Steve,

My host recommends Litespeed Cache which is what is installed.

I have disabled Litespeed cache and set WP_CACHE to false and still no change. Adding Products to the sitemap still results in a timeout. 

October 30, 2019
2:12 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

October 30, 2019
2:26 pm
Avatar
t_degarnham
Member
AIOSEOP
Forum Posts: 9
Member Since:
February 9, 2016
sp_UserOfflineSmall Offline

Hi Steve, 

Thanks for your help. 

My hosting company is not that helpful and I don’t want to move hosting again just because of this issue. I will just have to accept that this issue will remain unsolved. 

Thanks again.  

October 30, 2019
2:35 pm
Avatar
Steve Mortiboy
Admin
Forum Posts: 2151
Member Since:
January 5, 2012
sp_UserOfflineSmall Offline

** You currently do not have permission to see this post. To obtain access to these Premium Support Forums, please purchase a plugin and support subscription from Semper Plugins **

Forum Timezone: America/New_York
Most Users Ever Online: 964
Currently Online:
17
Guest(s)
Currently Browsing this Page:
1 Guest(s)
Top Posters:
Member Stats:
Guest Posters: 36
Members: 23040
Moderators: 0
Admins: 8
Forum Stats:
Groups: 4
Forums: 28
Topics: 2114
Posts: 9197
Newest Members:
youssefberrah854
Administrators: Michael TorbertPeter BayliesSupport TeamSteve MortiboyMatthew RobinsonSteve Klasen, Arnaud: 256Ashish Ravi
[i]
[i]
Skip to toolbar